#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)<table.*?>(.*)<\/table>"
Local $sString = "<table id='options_table'>" & @CRLF & _
" <tr><td colspan=3><font size="3" class="colors_productname">" & @CRLF & _
" <i><b>Color</b></i>" & @CRLF & _
" </font>" & @CRLF & _
" <br /><table cellpadding="0" cellspacing="0" border="0"><tr><td><img class="vCSS_img_line_group_features" src="/v/vspfiles/templates/192/images/Line_Group_Features.gif" /></td></tr></table>" & @CRLF & _
" </font></td></tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td align="right" vAlign="top">" & @CRLF & _
" <img src="/v/vspfiles/templates/192/images/clear1x1.gif" width="1" height="4" border="0"><br />" & @CRLF & _
" </td><td></td><td>" & @CRLF & _
" <SELECT name="SELECT___S15FTAN01___29" onChange="change_option('SELECT___S15FTAN01___29',this.options[this.selectedIndex].value)">" & @CRLF & _
" <OPTION value="176" >Ivory/Grey</OPTION>" & @CRLF & _
" </SELECT> " & @CRLF & _
" </td></tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td align="right" vAlign="top">" & @CRLF & _
" <img src="/v/vspfiles/templates/192/images/clear1x1.gif" width="1" height="4" border="0"><br />" & @CRLF & _
" </td><td></td><td>" & @CRLF & _
" <SELECT name="SELECT___S15FTAN01___31" onChange="change_option('SELECT___S15FTAN01___31',this.options[this.selectedIndex].value)">" & @CRLF & _
" <OPTION value="167" >0/3 months</OPTION>" & @CRLF & _
" <OPTION value="169" >3/6 months</OPTION>" & @CRLF & _
" <OPTION value="175" >6/9 months</OPTION>" & @CRLF & _
" </SELECT> " & @CRLF & _
" </td></tr>" & @CRLF & _
" </table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")