import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<table.*?>(.*)<\\/table>";
final String string = "<table id='options_table'>\n"
+ " <tr><td colspan=3><font size=\"3\" class=\"colors_productname\">\n"
+ " <i><b>Color</b></i>\n"
+ " </font>\n"
+ " <br /><table cellpadding=\"0\" cellspacing=\"0\" border=\"0\"><tr><td><img class=\"vCSS_img_line_group_features\" src=\"/v/vspfiles/templates/192/images/Line_Group_Features.gif\" /></td></tr></table>\n"
+ " </font></td></tr>\n"
+ " <tr>\n"
+ " <td align=\"right\" vAlign=\"top\">\n"
+ " <img src=\"/v/vspfiles/templates/192/images/clear1x1.gif\" width=\"1\" height=\"4\" border=\"0\"><br />\n"
+ " </td><td></td><td>\n"
+ " <SELECT name=\"SELECT___S15FTAN01___29\" onChange=\"change_option('SELECT___S15FTAN01___29',this.options[this.selectedIndex].value)\">\n"
+ " <OPTION value=\"176\" >Ivory/Grey</OPTION>\n"
+ " </SELECT> \n"
+ " </td></tr>\n"
+ " <tr>\n"
+ " <td align=\"right\" vAlign=\"top\">\n"
+ " <img src=\"/v/vspfiles/templates/192/images/clear1x1.gif\" width=\"1\" height=\"4\" border=\"0\"><br />\n"
+ " </td><td></td><td>\n"
+ " <SELECT name=\"SELECT___S15FTAN01___31\" onChange=\"change_option('SELECT___S15FTAN01___31',this.options[this.selectedIndex].value)\">\n"
+ " <OPTION value=\"167\" >0/3 months</OPTION>\n"
+ " <OPTION value=\"169\" >3/6 months</OPTION>\n"
+ " <OPTION value=\"175\" >6/9 months</OPTION>\n"
+ " </SELECT> \n"
+ " </td></tr>\n"
+ " </table>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}