#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?=.*?\d)(?=.*?\p{Ll})(?=.*?\p{Lu})(?!.*?\s)(?=.*?[^\p{L}\d])"
Local $sString = "Test@1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")