re = /^(?=.*?\d)(?=.*?\p{Ll})(?=.*?\p{Lu})(?!.*?\s)(?=.*?[^\p{L}\d])/
str = 'Test@1234'
# Print the match result
str.match(re) do |match|
puts match.to_s
end