#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(\/\w{30,50})(.+?\1){3,}"
Local $sString = "http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906" & @CRLF & _
"http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906" & @CRLF & _
"http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906" & @CRLF & _
"http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906" & @CRLF & _
"http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")