const regex = /(\/\w{30,50})(.+?\1){3,}/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\w{30,50})(.+?\\1){3,}', 's')
const str = `http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}