re = /^ *(\S[^\t]*)/m
str = 'abaft infamous\\tvase
drab marble
cover makeshift
skirt abrupt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end