#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\b| )([.,:;!]+)(?: |\b)"
Local $sString = "AA .BBB #unlikely to :) happen :) :) but managed anyway"
Local $sSubst = " \1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)