$re = '/(?:\b| )([.,:;!]+)(?: |\b)/m';
$str = 'AA .BBB #unlikely to :) happen :) :) but managed anyway';
$subst = " \1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;