import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+Content-[Tt]ype:\\s*\\S+";
final String string = "Accept-Ranges: bytes\n"
+ "Cache-Control: max-age=604800\n"
+ "Content-Type: text/html\n"
+ "Date: Fri, 14 Aug 2015 17:45:05 GMT\n"
+ "Etag: \"359670651\"\n"
+ "Expires: Fri, 21 Aug 2015 17:45:05 GMT\n"
+ "Last-Modified: Fri, 09 Aug 2013 23:54:35 GMT\n"
+ "Server: ECS (fty/2FA4)\n"
+ "X-Cache: HIT\n"
+ "x-ec-custom-error: 1\n"
+ "Content-Length: 1270\n\n\n"
+ "- 0%[ ] 0 --.-KB/s <!doctype html>\n"
+ "<html>\n"
+ "<head>\n"
+ " <title>Example Domain</title>\n\n"
+ " <meta charset=\"utf-8\" />\n"
+ " <meta http-equiv=\"Content-type\" content=\"text/html; charset=utf-8\" />\n"
+ " <meta name=\"viewport\" content=\"width=device-width, initial-scale=1\" />\n"
+ " <style type=\"text/css\">\n"
+ " body {\n"
+ " background-color: #f0f0f2;\n"
+ " margin: 0;\n"
+ " padding: 0;\n"
+ " font-family: \"Open Sans\", \"Helvetica Neue\", Helvetica, Arial, sans-serif;\n"
+ " \n"
+ " }\n"
+ " div {\n"
+ " width: 600px;\n"
+ " margin: 5em auto;\n"
+ " padding: 50px;\n"
+ " background-color: #fff;\n"
+ " border-radius: 1em;\n"
+ " }\n"
+ " a:link, a:visited {\n"
+ " color: #38488f;\n"
+ " text-decoration: none;\n"
+ " }\n"
+ " @media (max-width: 700px) {\n"
+ " body {\n"
+ " background-color: #fff;\n"
+ " }\n"
+ " div {\n"
+ " width: auto;\n"
+ " margin: 0 auto;\n"
+ " border-radius: 0;\n"
+ " padding: 1em;\n"
+ " }\n"
+ " }\n"
+ " </style> \n"
+ "</head>\n\n"
+ "<body>\n"
+ "<div>\n"
+ " <h1>Example Domain</h1>\n"
+ " <p>This domain is established to be used for illustrative examples in documents. You may use this\n"
+ " domain in examples without prior coordination or asking for permission.</p>\n"
+ " <p><a href=\"http://www.iana.org/domains/example\">More information...</a></p>\n"
+ "</div>\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}