$re = '/(^\s?[^qvx][^ijz]?[0-9]{1,2}[A,B,C,D,E,F,G,H,J,K,S,T,U,W]?\s?[0-9][^CIKMOV]{2}\s?)/mi';
$str = 'cv12ar
cv379ry
M1 1AA
M60 1NW
CR2 6XH
DN55 1PT
W1A 1HQ
EC1A 1BB
QC1A 1BB
EI1A 1BB
EI1x 1BB
cvvccvv
cvvc cvv
cvv ccvv
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);