import re
regex = re.compile(r"(^\s?[^qvx][^ijz]?[0-9]{1,2}[A,B,C,D,E,F,G,H,J,K,S,T,U,W]?\s?[0-9][^CIKMOV]{2}\s?)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("cv12ar\n"
"cv379ry\n"
"M1 1AA\n"
"M60 1NW\n"
"CR2 6XH\n"
"DN55 1PT\n"
"W1A 1HQ\n"
"EC1A 1BB\n"
"QC1A 1BB\n"
"EI1A 1BB\n"
"EI1x 1BB \n"
"cvvccvv\n"
"cvvc cvv\n"
"cvv ccvv\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")