$re = '/\'\s?\+\s?\w+?\s?\+\s?\'/';
$str = 'plugins.fireHook(\'filter:\' + template + \'.build\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);