re = /'\s?\+\s?\w+?\s?\+\s?'/
str = 'plugins.fireHook(\'filter:\' + template + \'.build\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end