$re = '/(?<token>\{((?:(Movie|Original))(?<separator>[- ._])(Clean|Original)?(Title|Filename)(The)?)(?::(?<customFormat>[a-z0-9|]+))?\})/mi';
$str = '{Movie Title}
{Movie CleanTitle}
{Movie Title The}
{Movie OriginalTitle}
{Movie CleanOriginalTitle}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);