re = /(?<token>\{((?:(Movie|Original))(?<separator>[- ._])(Clean|Original)?(Title|Filename)(The)?)(?::(?<customFormat>[a-z0-9|]+))?\})/mi
str = '{Movie Title}
{Movie CleanTitle}
{Movie Title The}
{Movie OriginalTitle}
{Movie CleanOriginalTitle}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end