using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\^(\((([^()]|(?1))*)\))";
string substitution = @"^{$2}";
string input = @"a^(x²)
b^(-(x²)+(y+(a+b)))
b^(-(x²)+(y+(a+b)))";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}