package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div id=".*">(.*)<\/div>`)
var str = `<div id="image">http://www.mpahmplakdjfe.co.uk/images/01.jpg</div>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}