$re = '/<div id=".*">(.*)<\/div>/';
$str = '<div id="image">http://www.mpahmplakdjfe.co.uk/images/01.jpg</div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);