const regex = new RegExp('(?P<only_aplha>[A-ü]*)', '')
const str = `äöéèàéèàôæ§¢§æ§´¿¿]|{}[¢§øæ¬°µ©¥å`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}