use strict;
my $str = 'interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 10.0.0.1 255.2555.255.0
no ip route-cache
!
interface Vlan20
no ip address
!
interface GigabitEthernet1/0/5
description PC-05
switchport access vlan 20
switchport mode access
switchport nonegotiate
shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/6
description PC-06
switchport access vlan 10
switchport mode access
switchport nonegotiate
switchport port-security maximum 2
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security mac-address aaaa.aaaa.aaaa vlan access
switchport port-security mac-address bbbb.bbbb.bbbb vlan access
spanning-tree portfast
spanning-tree bpduguard enable
!
end';
my $regex = qr/(?sm)interface (\S*)(?:(?!^!$).)*port-security.*?!$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}