package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`CUI: *\S+ +[A-Z]+ +(\d+)`)
var str = `CUI: RO39890982 BZ 347`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}