$re = '/CUI: *\S+ +[A-Z]+ +(\d+)/';
$str = 'CUI: RO39890982 BZ 347';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);