import Foundation
let pattern = #"^[a-zA-Z](?!.*(['-]).*\1)(?!.* )(?=.{0,19}$)[a-zA-Z0-9'-]*(?: (?<=[a-zA-Z] )[a-zA-Z][a-zA-Z0-9'-]*)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is aa
This is aa test
aa aa aa aa aa aa aa
This should m'atch
This a-lso'
This is a test
a b
aa
a
This is aa test
This' is aa tes
This is aaaa longer test
This sh'o'uld not
This sh-o-uld not
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)