const regex = /^[A-Za-z0-9]{15}(?:[A-Za-z0-9]{3})?$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z0-9]{15}(?:[A-Za-z0-9]{3})?$', 'gmi')
const str = `001i000001AWbWuGTA
001i000001AWbWugta
50130000000014c
50130000000014C
50130000000014ca
50130000000014cab
50130000000014cabde`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}