const regex = /\*\*(?<bold>(?:(?!\*\*).)+)\*\*|`(?<code>[^`]+)`|~~(?<strike>(?:(?!~~).)+)~~|\[(?<linkTitle>[^]]+)]\((?<linkHref>.*)\)|(?<normal>[^`[*~]+)|\*(?<italic>[^*]+)\*|(?<tara>[*~]{3,})|(?<sitara>[`[]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\*\\*(?<bold>(?:(?!\\*\\*).)+)\\*\\*|`(?<code>[^`]+)`|~~(?<strike>(?:(?!~~).)+)~~|\\[(?<linkTitle>[^]]+)]\\((?<linkHref>.*)\\)|(?<normal>[^`[*~]+)|\\*(?<italic>[^*]+)\\*|(?<tara>[*~]{3,})|(?<sitara>[`[]+)', 'g')
const str = `some normal and **bold with * gem*** but pure *italics* is alos there baby now ~~coming~~hola amigons~~strike~~ wooo lala what about blazing *********here baby ~~~~~~~~~baby \`baby\`\`\`[[[[[[[[[[[[[[[l]]]]int](href)[link](href)\`\`\`\`\`\`\`\`\`\``;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}