package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:https?:\/\/)(?:www\.)?(?:youtube|youtu)\.(?:be|com)\/[^\s]+`)
var str = `hi how are you check it https://www.youtube.com/watch?v=r_p8ZXIRFJI youtube link can be of this type https://youtu.be/_3tVL-ZAc4k`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}