using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Foo\b[^>]*>(.*?)</Foo>";
string input = @"<foo></foo> but <Foo>Hello</Foo> ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}