$re = '/<Foo\b[^>]*>(.*?)</Foo>/';
$str = '<foo></foo> but <Foo>Hello</Foo> ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);