package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\wæøåÆØÅ -]+`)
var str = `this_is_a_filename
this%is%not%a%filename
%+!?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}