$re = '/[\wæøåÆØÅ -]+/';
$str = 'this_is_a_filename
this%is%not%a%filename
%+!?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);