re = /.*(?!arm)\.dts$/m
str = './arch/arm64/boot/dts/ttt.dts
./arch/h8300/doot/dts/ttt.dts'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end