const regex = /(.*\.([Dd][Oo][Cc][Xx])|.*\.([Dd][Oo][Cc])|.*\.([Rr][Tt][Ff])|.*\.([Pp][Dd][Ff])|.*\.([Oo][Dd][Tt])$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*\\.([Dd][Oo][Cc][Xx])|.*\\.([Dd][Oo][Cc])|.*\\.([Rr][Tt][Ff])|.*\\.([Pp][Dd][Ff])|.*\\.([Oo][Dd][Tt])$)', 'gm')
const str = `test.docx
test.doc
test.odt
test.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}