$re = '/(.*\.([Dd][Oo][Cc][Xx])|.*\.([Dd][Oo][Cc])|.*\.([Rr][Tt][Ff])|.*\.([Pp][Dd][Ff])|.*\.([Oo][Dd][Tt])$)/m';
$str = 'test.docx
test.doc
test.odt
test.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);