$re = '/^\d{1,2}$|(100)/';
$str = '0.00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);