$re = '/\..+[a-z]/';
$str = 'data212.data';
$subst = ". data";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;