package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w_-]{1,255}`)
var str = `fggvjjjkjk-è(-'(çààà..++--`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}