$re = '/[\w_-]{1,255}/';
$str = 'fggvjjjkjk-è(-\'(çààà..++--';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);