# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\n]*\n)[^\n]*\n?/\1/g;t' <<< "foo
bar
test
123"