import Foundation
let pattern = #"([^\n]*\n)[^\n]*\n?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
foo
bar
test
123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)