$re = '/(^(?:(?![.\/()-]{2}).)*$)/m';
$str = '123()123
123--123
124((123
123(123)123-12-12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);