re = /(^(?:(?![.\/()-]{2}).)*$)/m
str = '123()123
123--123
124((123
123(123)123-12-12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end