package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(example\.com)`)
var str = `http://api.example.com/...
http://preview.example.com/...
http://www.example.com/...
http://purhcase.example.com/...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}