const regex = /(example\.com)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(example\\.com)', 'gim')
const str = `http://api.example.com/...
http://preview.example.com/...
http://www.example.com/...
http://purhcase.example.com/...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}