$re = '/(\w*)(\s+)(\d):(\d+)-?(\d*+)/m';
$str = 'John 1:3
Matthew 1:3-7
Matthew 1:13-17';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);