package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[0-9]{2}:?){3}`)
var str = `03:32:33
03:32:3
0:32`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}