import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!version-[\\d.]+$).*12\\.3.*$";
final String string = "bugfix-ISSUE-123-some-details-version-12.3\n"
+ "ISSUE-1234-some-other-details-version-12.3\n"
+ "bugfix-12.3\n"
+ "bugfix2-12.3\n"
+ "12.3stuff\n"
+ "stu12.3ff\n\n"
+ "// match everything above, but don't match anything from below\n\n"
+ "master\n"
+ "version-12.3\n"
+ "version-3.21\n"
+ "some-other-branch\n"
+ "bugfix-3.21\n"
+ "test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}