import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9](?:\\.[0-9]+)?$|^10(?:\\.0+)?$";
final String string = "0\n"
+ "0.1\n"
+ "0.12\n"
+ "0.123\n"
+ "10.0\n"
+ "10.00\n"
+ "9.99\n"
+ "1.12\n"
+ "2.34\n"
+ "11.1\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "4\n"
+ "5\n"
+ "6\n"
+ "7\n"
+ "8\n"
+ "9\n"
+ "1.1\n"
+ "2.12\n"
+ "3.32\n"
+ "4.45\n"
+ "5.67\n"
+ "6.98\n"
+ "7.12\n"
+ "8.3\n"
+ "9.56\n"
+ "10\n"
+ "1.1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}