$re = '/^[0-9](?:\.[0-9]+)?$|^10(?:\.0+)?$/m';
$str = '0
0.1
0.12
0.123
10.0
10.00
9.99
1.12
2.34
11.1
1
2
3
4
5
6
7
8
9
1.1
2.12
3.32
4.45
5.67
6.98
7.12
8.3
9.56
10
1.1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);