package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(^|\w)#(\w+)`)
var str = `#hash //works
#hash_hash //works
#hash_não // get just $hash_n`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}